
ELEN4017: Network Fundamentals 
Lab 4 

Lab 1: Introduction to Wireshark / HTTP analysis 
 
Objective 
 
The objective of this lab is to use the Wireshark tool to analyse features of TCP in 
the transport layer and IP in the network layer. 
 

Instructions: 
 

 This lab must be completed individually by each student. 

 There are two parts of this lab: ‘Lab4a’ about TCP and ‘Lab4b’ about IP.  

 The handout of ‘Lab4a’ contains instructions for carrying out the lab and 
has also got 12 questions. Similarly, handout for ‘Lab4b’ contains lab 
instructions as well as 15 associated questions.    

 An individual lab report, consisting of answers to the questions in the 
handouts, must be submitted to the demonstrators before the end of the 
session. 

 In addition to the report, demonstrators may ask questions to test your 
understanding of the material and marks for the lab will be allocated based 
on your ability to answer the questions. 



 

Lab 4a: TCP in Wireshark  

Supplement to Computer Networking: A Top-Down 

Approach, 6
th 

ed., J.F. Kurose and K.W. Ross  

“Tell me and I forget. Show me and I remember. Involve me and I 
understand.” Chinese proverb  
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In this lab, we’ll investigate the behavior of the celebrated TCP protocol in detail.  We’ll do so by 

analyzing a trace of the TCP segments sent and received in transferring a 150KB file (containing the 

text of Lewis Carrol’s Alice’s Adventures in Wonderland) from your computer to a remote server. 

We’ll study TCP’s use of sequence and acknowledgement numbers for providing reliable data transfer; 

we’ll see TCP’s congestion control algorithm – slow start and congestion avoidance – in action; and 

we’ll look at TCP’s receiver-advertised flow control mechanism.  We’ll also briefly consider TCP 

connection setup and we’ll investigate the performance (throughput and round-trip time) of the TCP 

connection between your computer and the server.  

Before beginning this lab, you’ll probably want to review sections 3.5 and 3.7 in the text
1

.  

1. Capturing a bulk TCP transfer from your computer to a remote 
server  

Before beginning our exploration of TCP, we’ll need to use Wireshark to obtain a packet trace of the 

TCP transfer of a file from your computer to a remote server. You’ll do so by accessing a Web page 

that will allow you to enter the name of a file stored on your computer (which contains the ASCII text 

of Alice in Wonderland), and then transfer the file to a Web server using the HTTP POST method (see 

section 2.2.3 in the text).  We’re using the POST method rather than the GET method as we’d like to 

transfer a large amount of data from your computer to another computer. Of course, we’ll be running 

Wireshark during this time to obtain the trace of the TCP segments sent and received from your 

computer.  
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References to figures and sections are for the 6
th 
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th 

ed., J.F. Kurose and K.W. Ross, Addison-Wesley/Pearson, 2012.  



 

 

Figure 1: Upload page for TCP Wireshark Lab 

 Start up your web browser. Go the http://gaia.cs.umass.edu/wiresharklabs/alice.txt and 

retrieve an ASCII copy of Alice in Wonderland. Store this file somewhere on your computer.  

 Next go to http://gaia.cs.umass.edu/wireshark-labs/TCP-wireshark-file1.html.  

 You should see a screen that looks like the screenshot shown in figure 1:  

 Use the Browse button in this form to enter the name of the file (full path name) on your 

computer containing Alice in Wonderland (or do so manually). Don’t yet press the “Upload 

alice.txt file” button.  

 Now start up Wireshark and begin packet capture (Capture->Start) and then press OK on the 

Wireshark Packet Capture Options screen (we’ll not need to select any options here).  

 Returning to your browser, press the “Upload alice.txt file” button to upload the file to the 

gaia.cs.umass.edu server.  Once the file has been uploaded, a short congratulations message 

will be displayed in your browser window.  

 Stop Wireshark packet capture. Your Wireshark window should look similar to the window 

shown in figure 2:  

 

 

 
If you are unable to run Wireshark on a live network connection, you can download a packet trace 

file that was captured while following the steps above on one of the author’s computers
2

. You may 

well find it valuable to download this trace even if you’ve captured your own trace and use it, as 

well as your own trace, when you explore the questions below.  

 

Do the following:  



 

Figure 2: Wireshark window showing packet capture 

2. A first look at the captured trace  

Before analyzing the behavior of the TCP connection in detail, let’s take a high level view of the 

trace.  

 First, filter the packets displayed in the Wireshark window by entering “tcp” (lowercase, 

no quotes, and don’t forget to press return after entering!) into the display filter 

specification window towards the top of the Wireshark window.  

What you should see is series of TCP and HTTP messages between your computer and 

gaia.cs.umass.edu.  You should see the initial three-way handshake containing a SYN message. 

You should see an HTTP POST message.  Depending on the version of Wireshark you are using, 

you might see a series of “HTTP Continuation” messages being sent from your computer to 

gaia.cs.umass.edu.   

Recall from our discussion in the earlier HTTP Wireshark lab, that there is no such thing as an 

HTTP Continuation message – this is Wireshark’s way of indicating that there are multiple TCP 

segments being used to carry a single HTTP message. 
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Download the zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip and extract the file tcpethereal-

trace-1. The traces in this zip file were collected by Wireshark running on one of the author’s computers, while 

performing the steps indicated in the Wireshark lab. Once you have downloaded the trace, you can load it into 

Wireshark and view the trace using the File pull down menu, choosing Open, and then selecting the tcp-ethereal-trace-1 

trace file.  



 
 

Figure 3: Wireshark window with TCP packets only  

In more recent versions of Wireshark, you’ll see “[TCP segment of a reassembled PDU]” in the Info 

column of the Wireshark display to indicate that this TCP segment contains data that belongs to an 

upper layer protocol message (in our case here, HTTP). You should also see TCP ACK segments 

being returned from gaia.cs.umass.edu to your computer.  

Answer the following questions, by opening the Wireshark captured packet file tcpethereal-trace-1 in 

http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip (that is download the trace and open that 

trace in Wireshark; see footnote 2).  

1. What is the IP address and TCP port number used by the client computer (source) that is 

transferring the file to gaia.cs.umass.edu?  To answer this question, it’s probably easiest to 

select an HTTP message and explore the details of the TCP packet used to carry this HTTP 

message, using the “details of the selected packet header window” (refer to Figure 2 in the 

“Getting Started with Wireshark” Lab if you’re uncertain about the Wireshark windows.  

2. What is the IP address of gaia.cs.umass.edu? On what port number is it sending and receiving 

TCP segments for this connection?  

3. What is the IP address and TCP port number used by your client computer (source) 

to transfer the file to gaia.cs.umass.edu?  

If you have been able to create your own trace, answer the following question:  

Since this lab is about TCP rather than HTTP, let’s change Wireshark’s “listing of captured packets” 

window so that it shows information about the TCP segments containing the HTTP messages, rather 

than about the HTTP messages. To have Wireshark do this, select Analyze->Enabled Protocols. Then 

uncheck the HTTP box and select OK. You should now see a Wireshark window that looks like the 

screenshot given in figure 3:  

 
 



 

This is what we’re looking for - a series of TCP segments sent between your computer and 

gaia.cs.umass.edu.  We will use the packet trace that you have captured (and/or the packet trace tcp-
ethereal-trace-1 in http://gaia.cs.umass.edu/wireshark-labs/wiresharktraces.zip; see earlier footnote) 

to study TCP behavior in the rest of this lab.  

3. TCP Basics  

Answer the following questions for the TCP segments:  

4. What is the sequence number of the TCP SYN segment that is used to initiate the TCP 

connection between the client computer and gaia.cs.umass.edu?  What is it in the segment that 

identifies the segment as a SYN segment?  

5. What is the sequence number of the SYNACK segment sent by gaia.cs.umass.edu to the client 

computer in reply to the SYN?  What is the value of the Acknowledgement field in the 

SYNACK segment?  How did gaia.cs.umass.edu determine that value? What is it in the 

segment that identifies the segment as a SYNACK segment?  

6. What is the sequence number of the TCP segment containing the HTTP POST command?  

Note that in order to find the POST command, you’ll need to dig into the packet content field 

at the bottom of the Wireshark window, looking for a segment with a “POST” within its 

DATA field.  

7. Consider the TCP segment containing the HTTP POST as the first segment in the TCP 

connection. What are the sequence numbers of the first six segments in the TCP connection 

(including the segment containing the HTTP POST)? At what time was each segment sent?  

When was the ACK for each segment received? Given the difference between when each 

TCP segment was sent, and when its acknowledgement was received, what is the RTT value 

for each of the six segments?  What is the EstimatedRTT value (see Section 3.5.3 in text) 

after the receipt of each ACK?   

 

Assume that the value of the EstimatedRTT is equal to the measured RTT for the first segment, 

and then is computed using the EstimatedRTT equation in section 3.5.3 for all subsequent 

segments.  

 

Note: Wireshark has a nice feature that allows you to plot the RTT for each of the TCP 

segments sent.  Select a TCP segment in the “listing of captured packets” window that is 

being sent from the client to the gaia.cs.umass.edu server.  Then select: Statistics->TCP 

Stream Graph->Round Trip Time Graph. 

 

 

8. What is the length of each of the first six TCP segments? (See the note below) 

 

Note: The TCP segments in the tcp-ethereal-trace-1 trace file are all less that 1460 bytes. This 

is because the computer on which the trace was gathered has an Ethernet card that limits the 

length of the maximum IP packet to 1500 bytes (40 bytes of TCP/IP header data and 1460 

bytes of TCP payload). This 1500 byte value is the standard maximum length allowed by 

Ethernet. If your trace indicates a TCP length greater than 1500 bytes, and your computer is 

using an Ethernet connection, then Wireshark is reporting the wrong TCP segment length; it 

will likely also show only one large TCP segment rather than multiple smaller segments. Your 

computer is indeed probably sending multiple smaller segments, as indicated by the ACKs it 

receives.  This inconsistency in reported segment lengths is due to the interaction between the 

Ethernet driver and the Wireshark software. We recommend that if you have this 

inconsistency, that you perform this lab using the provided trace file.  

 
 

 



 

 

 

9. What is the minimum amount of available buffer space advertised at the received for the 

entire trace?  Does the lack of receiver buffer space ever throttle the sender?  

10. Are there any retransmitted segments in the trace file? What did you check for (in the trace) 

in order to answer this question?  

11. How much data does the receiver typically acknowledge in an ACK?  Can you identify 

cases where the receiver is ACKing every other received segment (see Table 3.2 in the 

text).  

12. What is the throughput (bytes transferred per unit time) for the TCP connection? Explain 

how you calculated this value.  

 



 

© 2005-2012, J.F Kurose and K.W. Ross, All Rights Reserved  

  Lab 4b: IP in Wireshark  

Supplement to Computer Networking: A Top-Down 

Approach, 6
th 

ed., J.F. Kurose and K.W. Ross  

“Tell me and I forget. Show me and I remember. Involve me and I 
understand.” Chinese proverb  

 

In this lab, we’ll investigate the IP protocol, focusing on the IP datagram. We’ll do so by analyzing a 

trace of IP datagrams sent and received by an execution of the traceroute program. We’ll 

investigate the various fields in the IP datagram, and study IP fragmentation in detail.  

Before beginning this lab, you’ll probably want to review sections 1.4.3 in the text
1 

and section 3.4 of 

RFC 2151 [https://www.rfc-editor.org/rfc/rfc2151.txt] to update yourself on the operation of the 

traceroute program.  You’ll also want to read Section 4.4 in the text, and probably also have RFC 

791 [https://www.rfc-editor.org/rfc/rfc791.txt] on hand as well, for a discussion of the IP protocol.  

1. Capturing packets from an execution of traceroute  

In order to generate a trace of IP datagrams for this lab, we’ll use the traceroute program to send 

datagrams of different sizes towards some destination, X. Recall that traceroute operates by first 

sending one or more datagrams with the time-to-live (TTL) field in the IP header set to 1; it then sends 

a series of one or more datagrams towards the same destination with a TTL value of 2; it then sends a 

series of datagrams towards the same destination with a TTL value of 3; and so on.  Recall that a router 

must decrement the TTL in each received datagram by 1 (actually, RFC 791 says that the router must 

decrement the TTL by at least one). If the TTL reaches 0, the router returns an ICMP message (type 11 

– TTL-exceeded) to the sending host. As a result of this behavior, a datagram with a TTL of 1 (sent by 

the host executing traceroute) will cause the router one hop away from the sender to send an 

ICMP TTL-exceeded message back to the sender; the datagram sent with a TTL of 2 will cause the  
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Figure 4: Pingplotter window 

router two hops away to send an ICMP message back to the sender; the datagram sent with a TTL of 

3 will cause the router three hops away to send an ICMP message back to the sender; and so on.  In 

this manner, the host executing traceroute can learn the identities of the routers between itself 

and destination X by looking at the source IP addresses in the datagrams containing the ICMP TTL-

exceeded messages.  

We’ll want to run traceroute and have it send datagrams of various lengths.  

 Windows. The tracert program provided with Windows does not allow one to change the 

size of the ICMP echo request (ping) message sent by the tracert program. A nicer 

Windows traceroute program is pingplotter, available both in free version and shareware 

versions at http://www.pingplotter.com. Download and install pingplotter, and test it out by 

performing a few traceroutes to your favorite sites.  The size of the ICMP echo request 

message can be explicitly set in pingplotter by selecting the menu item Edit-> Options-

>Packet Options and then filling in the Packet Size field.  The default packet size is 56 bytes.  

Once pingplotter has sent a series of packets with the increasing TTL values, it restarts the 

sending process again with a TTL of 1, after waiting Trace Interval amount of time. The value 

of Trace Interval and the number of intervals can be explicitly set in pingplotter.  

 

 Linux/Unix/MacOS. With the Unix/MacOS traceroute command, the size of the UDP 

datagram sent towards the destination can be explicitly set by indicating the number of bytes 

in the datagram; this value is entered in the traceroute command line immediately after 

the name or address of the destination.  For example, to send traceroute datagrams of 2000 

bytes towards gaia.cs.umass.edu, the command would be:  %traceroute 

gaia.cs.umass.edu 2000  

Do the following:  

 Start up Wireshark and begin packet capture (Capture->Start) and then press OK on the 

Wireshark Packet Capture Options screen (we’ll not need to select any options here).  

 If you are using a Windows platform, start up pingplotter and enter the name of a target 

destination in the “Address to Trace Window.”  Enter 3 in the “# of times to Trace” field, so 

you don’t gather too much data.  Select the menu item Edit >Advanced Options->Packet 

Options and enter a value of 56 in the Packet Size field and then press OK.  Then press the 

Trace button.  You should see a pingplotter window that looks something like figure 4:  

    



 

Next, send a set of datagrams with a longer length, by selecting Edit->Advanced Options-

>Packet Options and enter a value of 2000 in the Packet Size field and then press OK. Then 

press the Resume button.  

Finally, send a set of datagrams with a longer length, by selecting Edit>Advanced Options-

>Packet Options and enter a value of 3500 in the Packet Size field and then press OK.  Then 

press the Resume button.  

Stop Wireshark tracing.  

 If you are using a Unix or Mac platform, enter three traceroute commands, one with a length of 

56 bytes, one with a length of 2000 bytes, and one with a length of 3500 bytes.  

Stop Wireshark tracing.  

If you are unable to run Wireshark on a live network connection, you can download a packet trace file that 

was capture If you are unable to run Wireshark on a live network connection, you can download a packet 

trace file that was captured while following the steps above on one of the author’s Windows computers2. 

You may well find it valuable to download this trace even if you’ve captured your own trace and use it, as 

well as your own trace, when you explore the questions below.       

2. A look at the captured trace  
 
In your trace, you should be able to see the series of ICMP Echo Request (in the case of Windows 

machine) or the UDP segment (in the case of Unix) sent by your computer and the ICMP TTL-exceeded 

messages returned to your computer by the intermediate routers.  In the questions below, we’ll assume you 

are using a Windows machine; the corresponding questions for the case of a Unix machine should be 

clear.  

1. Select the first ICMP Echo Request message sent by your computer, and expand the Internet 

Protocol part of the packet in the packet details window, as shown in figure 5.  What is the IP 

address of your computer?  

2. Within the IP packet header, what is the value in the upper layer protocol field?  

3. How many bytes are in the IP header? How many bytes are in the payload of the IP datagram?  

Explain how you determined the number of payload bytes. 

  

4. Has this IP datagram been fragmented?  Explain how you determined whether or not the datagram 

has been fragmented.  
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Download the zip file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip and extract the file ipethereal-

trace-1. The traces in this zip file were collected by Wireshark running on one of the book author’s computers, while 

performing the steps indicated in the Wireshark lab. Once you have downloaded the trace, you can load it into 

Wireshark and view the trace using the File pull down menu, choosing Open, and then selecting the ip-ethereal-trace-1 

trace file.  



 

Figure 5: Expanding the IP portion of the ICMP packet 
 

 Next, sort the traced packets according to IP source address by clicking on the Source column header; a 

small downward pointing arrow should appear next to the word Source. If the arrow points up, click on the 

Source column header again.  Select the first ICMP Echo Request message sent by your computer, and 

expand the Internet Protocol portion in the “details of selected packet header” window.  In the “listing of 

captured packets” window, you should see all of the subsequent ICMP messages (perhaps with additional 

interspersed packets sent by other protocols running on your computer) below this first ICMP.  Use the down 

arrow to move through the ICMP messages sent by your computer.  

5. Which fields in the IP datagram always change from one datagram to the next within this series of 

ICMP messages sent by your computer?  

6. Which fields stay constant?  Which of the fields must stay constant? Which fields must change?  

Why?  

7. Describe the pattern you see in the values in the Identification field of the IP datagram  

 

 

Next (with the packets still sorted by source address) find the series of ICMP TTL-exceeded replies sent to 

your computer by the nearest (first hop) router.  

8. What is the value in the Identification field and the TTL field?  

9. Do these values remain unchanged for all of the ICMP TTL-exceeded replies sent to your computer 

by the nearest (first hop) router?  Why? 

 

 
 

  

 



 

 

 

 

 Fragmentation  

Sort the packet listing according to time again by clicking on the Time column.  

10. Find the first ICMP Echo Request message that was sent by your computer after you changed the 

Packet Size in pingplotter to be 2000. Has that message been fragmented across more than one IP 

datagram?  [Note: if you find your packet has not been fragmented, you should download the zip 

file http://gaia.cs.umass.edu/wireshark-labs/wireshark-traces.zip and extract the ipethereal-trace-1 
packet trace. If your computer has an Ethernet interface, a packet size of 2000 should cause 

fragmentation.
3

]  

 

11. Observe the first fragment of the fragmented IP datagram. What information in the IP header 

indicates that the datagram been fragmented?  What information in the IP header indicates whether 

this is the first fragment versus a latter fragment? How long is this IP datagram?  

 

12. Observe the second fragment of the fragmented IP datagram. What information in the IP header 

indicates that this is not the first datagram fragment?  Are the more fragments?  How can you tell?  

 

13. What fields change in the IP header between the first and second fragment?  

 

Now find the first ICMP Echo Request message that was sent by your computer after you changed the 

Packet Size in pingplotter to be 3500.  

14. How many fragments were created from the original datagram?  

 

15. What fields change in the IP header among the fragments?  
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The packets in the ip-ethereal-trace-1 trace file in http://gaia.cs.umass.edu/wireshark-labs/wiresharktraces.zip are 

all less that 1500 bytes. This is because the computer on which the trace was gathered has an Ethernet card that limits 

the length of the maximum IP packet to 1500 bytes (40 bytes of TCP/IP header data and 1460 bytes of upper-layer 

protocol payload).  This 1500 byte value is the standard maximum length allowed by Ethernet.  If your trace indicates a 

datagram longer 1500 bytes, and your computer is using an Ethernet connection, then Wireshark is reporting the wrong 

IP datagram length; it will likely also show only one large IP datagram rather than multiple smaller datagrams.. This 

inconsistency in reported lengths is due to the interaction between the Ethernet driver and the Wireshark software. We 

recommend that if you have this inconsistency, that you perform this lab using the ip-ethereal-trace-1 trace file.  

 


